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Notices 

Copyright 

Copyright 2016 Picarro, Inc. All rights reserved.  

Information in this document is furnished pursuant to Customer’s purchase or non-disclosure agreement 

with Picarro and may be used or copied only in accordance with the terms of such agreement.  The 

software described in this document is owned by Picarro, Inc. (or its licensors) and protected by U.S. 

copyright law and may not be copied on any medium except as specifically authorized in the 

purchase/lease agreement. 

Disclaimer 

Picarro, Inc. reserves the right to revise this document and to make changes from time to time. 

Trademarks 

Picarro and the Picarro logo are trademarks or registered trademarks of Picarro, Inc. Third-party product 

names and related marks used in this document are trademarks or registered trademarks of their 

respective owners. Use of third-party product names and marks does not imply any affiliation or 

endorsement by such parties. 

FCC Warning 

This equipment has been tested and found to comply with the limits of a Class A digital device, pursuant 

to part 15 of the FCC Rules. These limits are designed to provide reasonable protection against harmful 

interference when the equipment is operated in a commercial environment. This equipment generates, 

uses, and can radiate radio frequency energy and, if not installed and used in accordance with the 

instruction manual, may cause harmful interference to radio communications. Operation of this equipment 

in a residential area is likely to cause harmful interference in which case the user will be required to 

correct the interference at his own expense. 

 

CE Mark Warning 

This is a Class A product. In a domestic environment, this product may cause radio interference, in which 

case the user may be required to take adequate measures. 

 

Canada ICES Warning 

This product complies with CAN ICES-3 (A)/NMB-3(A) 
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CHAPTER 1 Overview 

The Picarro G4301 provides extremely precise and simultaneous measurements of CO2, CH4, and water 

vapor at ambient levels. This instrument uses time-based, optical absorption spectroscopy of the target 

gases to determine concentration. It is based on wavelength-scanned cavity ring-down spectroscopy 

(WS-CRDS), a technology in which light re-circulates many times through the sample, creating a very 

long effective path length for the light to interact with the sample, thus, enabling excellent detection 

sensitivity in a compact and rugged instrument.  

The unique backpack design lets you easily transport the analyzer when moving to a new location, 

allowing you to operate the analyzer in remote areas, especially those that can only be reached by foot, 

and on the move. The battery-powered analyzer is self-sufficient and has an autonomy of 8 hrs. 

This document describes how to set up and use Picarro G4301. 

Conventions 

Within this manual, you may see graphic icons representing important information in the text. The purpose of 

these icons is to provide a visual convention to alert you of an important note or safety hazard alert. 

 Reminders are helpful hints for procedures listed in a document.  

 

 Notes include an important procedure that you should be aware of before proceeding. Notes also 

provide tips or additional insight into a feature, option, task, etc. 

 

 CAUTION ALERTS THE USER OF A POTENTIAL DANGER TO EQUIPMENT, DATA, OR TO THE 

USER. 

 

 A WARNING IS USED TO WARN AGAINST IMMINENT DANGER TO THE USER. 
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CHAPTER 2 Picarro G4301 Components 
and Setup 

This section describes how to unpack and set up the Picarro G4301. It also includes some important 

notes to follow when using your Picarro G4301. Please ensure that you review this information carefully. 

Finally, this section also describes how to properly pack up and store the Picarro G4301. 

Safety Notes 

Please read and understand the following notes thoroughly before you begin using the Picarro G4301. 

The Picarro Analyzer complies with the following safety standards: 

CE: IEC EN61010-1:2010 (safety) and EN61326-1:2013 (EMC) 

requirements for electrical equipment for measurement, control and 

laboratory use. 

FDA/CDRH 21 CFR Parts 1040.10-11 

 

 LASER SAFETY: THE PICARRO ANALYZER IS CLASSIFIED AS A CLASS 1 EMBEDDED LASER 

PRODUCT 

 CLASS 3B INVISIBLE LASER RADIATION WHEN OPEN, AVOID EXPOSURE TO THE BEAM 

 

There are lasers used inside the analyzer, emitting a maximum of 50 mW of CW light in the near-infrared. 

There are no user serviceable components within the analyzer enclosures and so you should not open 

any of these enclosures within the analyzer. FAILURE TO FOLLOW THIS INSTRUCTION COULD 

RESULT IN EXPOSURE TO CLASS IIIB LASER RADIATION, which can permanently damage eyes and 

skin. 

Safety Labels: The following label is affixed to the main lid of the cavity enclosure. 
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Please contact Picarro if you have any questions regarding the safe operation of this equipment. Refer to 

the appropriate section within this document relating to pump and filter replacement procedures. 

 

 DO NOT OPERATE IN AN EXPLOSIVE ATMOSPHERE. 

 

 DO NOT USE THIS DEVICE IN THE RAIN OR ALLOW THE PICARRO G4301 TO GET WET. 

 

 DO NOT DROP THE PICARRO G4301. 

 

 DO NOT USE PICARRO G4301 IF THE WEATHER IS COLDER THAN 0°C OR WARMER THAN 

45°C. IT IS IMPERATIVE THAT THE ANALYZER HAVE ADEQUATE VENTILATION AND/OR 

COOLING TO MAINTAIN THE AMBIENT TEMPERATURE BELOW 45 °C WHEN OPERATING. 

FAILURE TO PROVIDE ADEQUATE AIRFLOW TO THE PICARRO G4301 WILL RESULT IN 

OVERHEATING OF THE ANALYZER, CAUSING A SHUTDOWN AND POTENTIAL DAMAGE. 

 

 IF THE ANALYZER HAS BEEN STORED AT LESS THAN 0°C, ALLOW THE COMPONENTS TO 

EQUALIZE TO ROOM TEMPERATURE BEFORE USING THE DEVICE. 

 

 THE CAVITY BOX CONTAINS NO USER SERVICEABLE COMPONENTS. DO NOT ATTEMPT 

REPAIRS; INSTEAD REPORT ALL PROBLEMS TO PICARRO. 

 

CAUTION  
CLASS 3B INVISIBLE LASER 

RADIATION WHEN OPEN  
AVOID EXPOSURE TO THE BEAM 

2.125” 

1” 
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Included Items 

The following items are included with your Picarro G4301 shipment. Inspect each item to assure it is not 

damaged. If any of these items are missing or damaged, contact Picarro for a replacement.  

We recommend that you keep the shipping package. This shipping package is a very good way to ship 

the system to other labs or field stations. If a chance exists that the Picarro G4301 may get wet during 

transport, then do not ship the device. Instead, please contact Picarro for options on transporting this 

system. 

Table 1. Included items 

Item Description 

One Picarro G4301 

analyzer 

Includes all of the data acquisition, control, and communications hardware and firmware 

to perform all gas handling, spectral collection, and analysis. 

One A/C Battery 

Charger 

Charger works on 110VAC or 230VAC outlet and plugs into the charger port on the 

Gascouter. 

One Attached Battery One battery is already attached to your Picarro G4301. Note that additional batteries are 

available for purchase. 

Tubing ▪ Inlet tubing with male connector 

▪ Outlet tubing with female connector 

External Inlet Filter Filter attached to the inlet line to provide additional protection by trapping dust and water 

particles. 

Items Not Included 

The following additional items are not included but can be used with your Picarro G4301. 

Table 2. Items not included 

Item Description 

Mobile device - phone or 

tablet 

A mobile device (phone or tablet) is used to log on to the analyzer Web-based GUI and 

view real-time data.  

Laptop or tablet  A laptop or tablet with a wireless connection can be attached to your analyzer. When 

using either of these devices, you can remote desktop to the analyzer and view the 

analyzer GUI. 

Docking station Picarro G4301 provides two USB3 ports. With a docking station, you can attach a 

monitor, mouse, and keyboard giving you direct access to the analyzer. A direct 

connection eliminates the need to connect to the analyzer via Remote Desktop.  

Backup Battery A second battery is useful if you cannot regularly recharge the primary battery.  
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Picarro G4301 Components 

Picarro G4301 includes the following components: 

▪ Battery 
▪ Lasers 
▪ CPU 
▪ Cavity Box 
▪ Vacuum Pump 
▪ Connection Ports 

 

Figure 1. Components 

Picarro G4301 Connections 

The Picarro G4301 backplate includes the following items:  

▪ Power On button 
▪ Two USB3 ports, allowing you to hook up a monitor, keyboard, or even a docking station 
▪ Gas Inlets/Outlet 
▪ DC Power connector 

The following image shows the backplate of the Picarro G4301. 
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Figure 2. Picarro G4301 backplate 

Battery Installation and Charging 

The Picarro G4301 comes with one installed battery. A second/backup battery is available for purchase. 

This section describes how to swap out and charge a dead battery. 

Replacing the Battery without interrupting the measurements 

1. Ensure that the battery is set to 19 V 

2. To replace the battery without turning off the analyzer, connect the spare lead to the charged battery 

and unplug the battery lead from the top of the dead battery. 

 

Figure 3. Unplugging the battery cable 

3. Unhinge the battery buckle. 
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Figure 4. Opening the battery casing 

4. Carefully remove the battery from the felt casing. 

5. Insert powered battery into the felt casing. 

6. Re-hinge the battery buckle, and re-attach the battery lead. 

Charging the Battery 

To recharge the battery, leave the battery plugged to the GasScouter and connect the battery charger to 

the DC power input of the GasScouter on one end and to a power outlet (110 VAC or 230 VAC 

depending on your region) on the other end of the charger.  

 Any time the analyzer is plugged in to a power source, the battery will charge. 

 

 Ensure the battery is set to 19 V and not 15 V. 

 The battery charging input voltage is between 12 to 19V. The battery consumes 3A at 16V when 

charging. 
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Inlet Filter Installation 

The Picarro G4301 comes with an external inlet filter to protect the instrument from dust and water 

particles. Connect the filter to the inlet port before operating the analyzer. 

 

 

Figure 5. Inlet Filter Connection 

 

Transportation and Storage 

The following procedure can be used to repack the instrument into the original carton and prepare it for 

either transportation or storage. 

Clean, dry gas should be attached to the instrument prior to shutting down. This prevents condensation 

inside the system during storage or shipment. 

1. Shut down Picarro G4301 by shutting down the analyzer (if it is running), then pressing the Power 

button on the backplate. (Refer to Shutting Down Picarro G4301 for more information.) 

2. Detach any attached items, such as a docking station, laptop, tablet, etc. 

3. Pack the Picarro G4301 and all accessories in the original shipping container, ensuring that all of the 

foam pieces are in place to protect the device during shipping. 

 CAUTION: WHEN SHIPPING OR RELOCATING THE PICARRO G4301, IT IS IMPORTANT TO 

PROTECT IT FROM MECHANICAL SHOCKS. FAILURE TO DO SO CAN COMPROMISE ITS 

MECHANICAL INTEGRITY. 
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CHAPTER 3 Operation 

This section describes the following basic operations of your Picarro G4301: 

▪ Starting Picarro G4301 
▪ Connecting to the Analyzer GUI 
▪ Stopping the Logs 
▪ Shutting Down Picarro G4301 

Starting Picarro G4301 

Press the Power button on the backplate of the analyzer to start Picarro G4301. 

 

Figure 6. Power button 

 The LED light on the Power button will glow green when the device is powered on. 

The software to operate Picarro G4301 will start automatically after the operating system has loaded. If a 

monitor is connected the analyzer, then the user interface will appear a few seconds after the instrument 

software starts along with the following status messages. 

 Contact Picarro Support if you encounter any error messages during startup. 
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Entering Measurement 

Spectral scanning has started. Concentration measurements will be available in approximately 30 

seconds. The instrument will continue to scan and report concentration measurements until the 

instrument is shutdown using the procedure below. 

Measuring 

This is the normal mode of operation after startup has completed. 

Reading/Monitoring Data 

Real-time data can be monitored and viewed on the Web-based GUI using a mobile device. Users can 

also remotely access the analyzer GUI using a tablet or laptop. If a docking station with a monitor and 

keyboard is attached to the analyzer, then users can directly connect to the analyzer GUI. 

 

Figure 7. G4301 connection options 

Logging On to the Web-Based GUI 

The Web-based GUI streams real-time data for dry mol CO2 and CH4 readings directly to your mobile 

device while walking with your Picarro G4301. 

Perform the following steps to log on to the Web-based GUI. 

1. Ensure that Picarro G4301 is powered on and that your mobile device is within a few feet of the 

analyzer. 

2. On your mobile device, search for and select the "Nomadxxx" wireless network. 

3. Enter "picarropicarro" for this password, or enter the password provided by Picarro, Inc. 

4. When the device is attached to the "Nomadxxxx" network, open a Chrome™ or Safari® browser, and 

navigate to 192.168.173.1:3000. 

Upon successful completion, you will see a display similar to the following on your mobile device. 
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Figure 8. Mobile view GUI 

At this point, you can begin scouting and viewing real-time data on your mobile device. Refer to Using the 

Web-Based GUI for more information. 

Connecting to the Analyzer GUI 

Based on the device(s) that you attach to Picarro G4301, select one of the following methods to connect 

to the analyzer GUI and review the collected data. 

Table 3. Connection options 

Device(s) Connection Steps 

Docking station with a monitor, keyboard, 

and mouse 

Refer to Direct Connection to Analyzer GUI 

Laptop or Tablet Refer to Remote Desktop Connection on a Laptop or Tablet 

Once connected, you will see a screen similar to the following. Refer to Using the Analyzer GUI for 

information on how to use the GUI.  
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Figure 9. The Analyzer GUI 

Direct Connection to Analyzer GUI 

1. Ensure that Picarro G4301 is powered on. 

2. Attach docking station to one of the USB3 ports. From here, you can connect a monitor, keyboard, 

and mouse and be directly connected to the analyzer. 

Remote Desktop Connection on a Laptop or Tablet 

1. Ensure that Picarro G4301 is powered on. 

2. Power-on the laptop and ensure that you have a strong Wi-Fi connection to the Nomadxxxx network. 

3. Launch the Remote Desktop Connection application for remote access. (For PC, this is Windows 

Remote Desktop; for MAC, iOS, or Android, this is Microsoft Remote Desktop.) 

4. In the Computer box, enter 192.168.173.1. 

5. When prompted, enter the following information for the and password: 

Username: Corp\picarro 

Password: Extreme_Science! 

Stopping the Logs 

The Picarro G4301 analyzer continuously collects data while the device is powered on. In some cases, 

you may want to stop the current analyzer data collection but still leave the device powered on. To do 

this, press the Stop User Log(s) button on the Analyzer GUI. 
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Figure 10. Stop User Log(s) 

Shutting Down Picarro G4301 

Preparing for Shutdown 

Be sure to dry the air in the cavity prior to shutting down the analyzer. Moisture trapped in the cavity when 

it is out of service can result in condensation damage. 

We recommend lowering the water concentration down to 1,000 ppm or 0.1%. This can be done by 

connecting an air dryer canister to the analyzer. Note that it will take approximately 2-3 min to bring the 

water concentration to an acceptable level. 

Soft Shutdown 

A soft shutdown will turn off the analyzer computer, but it will not turn off the power supply to the pump. 

▪ Web-based GUI 

Click on the Shutdown button on the Web-based GUI. A message will display the current water 

concentration of the gas in the analyzer. Once the water concentration is below the recommended 

limit, confirm the shutdown by clicking on Shutdown Analyzer. 
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Figure 11. Shutdown Window 

 

Make sure the water concentration is below 1,000 ppm or 0.1%. To dry the air in the cavity, follow the 

procedure described in Preparing for Shutdown. 

Hard Shutdown 

A hard shutdown will suppress the power from the battery to the analyzer. Press the Power button to 

perform a hard shutdown. The LED power light will stop glowing green when the device is fully powered 

down. 

 

Figure 12. Power button 
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 We recommend that you perform a hard shutdown only after a soft shutdown. It is possible for the data 

file to become corrupted if a hard shutdown is conducted without first performing a soft shutdown. 

In Case of a Drained Battery 

If the main battery dies and power to the analyzer is cut-off, the analyzer will cease operation. However, 

when the power is reapplied, the analyzer will restart automatically, and the Picarro software tools will 

properly close out previous files and open new files for data collection so that previously collected data, 

instrument diagnostics, and other parameters recorded up to the time of power outage are retained. 

If the risk of power outages may be part of a routine-operating environment, Picarro recommends either 

purchasing a second battery and/or providing an uninterrupted power supply that will work to prevent the 

potential operating system and software corruption problems that can occur with repeated crashes. 
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CHAPTER 4 Alarms 

On Analyzer GUI 

An alarm panel is used to monitor the status of the internal instrument alarms. These indicators provide 

information about the system status, IP connectivity, gas concentration alarms such as “CH4 Too 

High/Low.”, and the Battery Alarm. 

The Battery Alarm indicator will light up when the battery voltage falls below a threshold. This will indicate 

that less than 10 minutes of battery life remains and the user shall proceed with the one of the following 

options: 

1) Charge the battery by connecting the analyzer’s DC power input to the battery charger’s DC 

output and by connecting the battery charger to a power outlet (110 VAC or 220 VAC depending 

on your region). 

2) Exchange the battery with a backup battery. 

3) Shutdown the analyzer to ensure that the data files are saved properly.  

The gas concentration alarms are off (grayed) when the respective concentrations are below a certain 

value, and they are illuminated when the respective concentrations are above/below a certain value. 

 

Figure 13. Alarm Panel 

To view an alarm's settings, click on the alarm in the Analyzer GUI. A dialog box will appear, indicating 

the alarm setting and (if available) allowing the user to enable it or change the settings: 
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Figure 14. Setting a CH4 alarm 

 The System and IPV Connectivity alarms are informational only. These alarms are always enabled. They 

do not require or allow any user configurations. 

Type the value you want to set the alarm to, then select the Enable alarm check box. Press OK to 

complete your changes, or press Cancel to reject the alarm value. If you do nothing, the dialog box will 

disappear, and the alarm value will remain unchanged. The units are those that appear in the GUI graph. 

 

On Web-Based GUI 

A low-battery notification will pop up when the battery voltage falls below a threshold. It will indicate that 

only 10 minutes of battery life remains. The user can close the window by clicking on OK. It will re-appear 

after a couple of minutes. 

At this time, it is recommended to proceed with the one of the following options: 

1) Charge the battery by connecting the analyzer’s DC power input to the battery charger’s DC 

output and by connecting the battery charger to a power outlet (110 VAC or 220 VAC depending 

on your region). 

2) Exchange the battery with a backup battery. 

3) Shutdown the analyzer to ensure that the data files are saved properly.  
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Figure 15. Low-Battery alarm 
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CHAPTER 5 The Picarro G4301 Web-
Based GUI 

The Web-based GUI connects to the analyzer using a Wi-Fi connection. This GUI outputs two graphs ( 

CO2 and CH4) and includes a limited set of controls. This section describes the features and functions 

available in the Picarro G4301 Web-based GUI. 

Using the Web-Based GUI 

On your mobile device open a supported browser and navigate to 192.168.173.1:5000. (Refer to Logging 

On to the Web-Based GUI for more information.) Upon successful connection, an image similar to the 

following will display. 

 

Figure 16. Web-based GUI 

As you walk around with Picarro G4301, the Web-based GUI streams real-time data for CH4 and CO2. 

The X-axis provides the current time. Using your fingers, you can squeeze the range bars below the X-

axis to view a smaller time-period. 
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Figure 17. Narrowing the time range 

The Y-axis shows the range of the current ppm values. 

Use the Clear button to wipe the current data from the graphs. The analyzer will continue to run and 

update the screen with new data, which will be included in the current data file. 

Use the Restart UserLog button to clear the current data from the graph and to begin collecting 

information for a new data file. 

Use the Shutdown button to end your connection to the analyzer and to power down Picarro G4301. 

When you select this button, a message will display reminding you to connect dry gas to the system 

before shutting down. Refer to Shutting Down Picarro G4301 (page 13) for more information. 

 DRY GAS PROTECTS THE CAVITY FROM MOISTURE DAMAGE. THIS STEP SHOULD NOT BE 

SKIPPED UNLESS YOU ARE IN A VERY DRY ENVIRONMENT. 
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CHAPTER 6 The Picarro G4301 Analyzer 
GUI 

This section describes the features and functions available in the Picarro G4301 Analyzer GUI. 

Using the Analyzer GUI 

Connect to analyzer GUI, either through a direct or remote connection. Refer to Connecting to the Analyzer 

GUI  for more information. 

The remainder of this chapter describes how to use the analyzer GUI application. 

Analyzer GUI Overview 

The Picarro Analyzer GUI includes the following components and navigation elements. 

 

 

Figure 18. Graphical elements of the analyzer GUI 

The following table provides a brief description of these elements. These are described in greater detail in the 

sections that follow. 
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Table 4. GUI Navigation Elements 

Navigation Element Description 

Settings, View, Tools, and Help 

menus 

These menus provide options to specify when using the analyzer GUI 

Alarm Panel Monitors the status of the internal instrument alarms 

Digital Readouts Shows the latest values recorded for a specified data key for each data window 

Instrument Status Only displays if View > Show Instrument Status is enabled. Shows the current 

temperature and pressure of the analyzer.  

Shutdown and Stop Logs Enables you to shutdown the analyzer or to keep the analyzer powered on but 

discontinue collecting logs 

Data log filename and path Shows the filename and path of the active data log 

Status log window Streams instrument status messages 

Data Source, Data Key, and 

Precision drop downs. Axis 

Autoscaling and Reset Buffers. 

Drop downs determine the data stream that displays in the data windows. 

Precision specifies the precision on the y-axis, between 0 and 4 digits or to auto-

scale. Reset buffers clears data from the data windows.  

Data buffer level meter Shows the amount of internal memory used 

Data windows Displays a graph of any stream of data vs. system time, with a format of 

hh:mm:ss. 

Settings, View, Tools, and Help Menus 

This section describes the menu items that are available in the analyzer GUI. 

Settings Menu 

The Settings menu has a single option: Change GUI Mode from Standard to Service. Service Mode is a 

password protected mode with additional operational and measurement parameters. Selecting this entry 

opens the Cavity Ring-Down Spectrometer Controller. 

 Service Mode is reserved for Picarro service operators only. 

View Menu 

The View menu includes the following options: 
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• Lock/Unlock time axis when zoomed: When locked, forces the two graphs to display the same time scale 
during zoom. 

• Show/Hide statistics: Toggles the measurement statistics display. See Digital Readouts. 
• Show/Hide instrument status: Toggles the instruments status display. See Instrument Status. 

Tools Menu 

The Tools menu includes the following options: 

• User Calibration: Opens the User Calibration window. The calibration slope and intercept can be entered, 
and their effects immediately seen in the data. Refer to Calibration Procedure (page 43) for more 
information. 

 User Calibration is a password-protected form, and the default password is “picarro”. This password can 

be reset in the QuickGui.ini file in the instrument directory: 

“C:\Picarro\G2000\AppConfig\Config\QuickGUI\” under the section: 

[Authorization] UserCalPassword = Picarro Show/Hide Value 

• Sequencer GUI: Toggles the display of the External Valve Sequencer window. 

Help Menu 

Provides "About" information, including the version number of the instrument. 

Alarm Panel 

The Alarm panel shows the alarms that are available on the analyzer. You can click on the IPV 

Connectivity and System alarms to view information about these alarms. Click on the CH4 Alarm or the 

H2O Alarm to configure settings to trigger these alarms. For example: 

 

Figure 19. CH4 Alarm 
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Digital Readouts 

The Digital Readouts section displays the latest value recorded for the selected Data Key for each Data 

Window. Changing the Data Key changes the Digital Readout and changes the Data Window view. If View > 

Show Statistics is enabled, then the mean, standard deviation, and slope of the data in the graph is 

dynamically calculated and indicated below the digital concentration readout. These numbers change to 

reflect statistics of whatever data is in the data window. 

Instrument Status 

If these parameters are enabled in View > Show Instrument Status, then digital readouts for Warm Box 

temperature, Cavity Temperature, and Cavity Pressure will display to the left of the main trend graphs. 

Shutdown and Start/Stop User Log(s) 

Start/Stop User Log(s) button 

When powered on, the analyzer automatically records all data collected on the instrument and 

saves it for later analysis. In addition, the user can record a separate data log file. Press Start User 

Log(s) if you want the instrument to start recording a separate data file. A dialog box will appear 

prompting you for a filename and location. This logging information displays in the Data Log Filename 

and Path section. Press Stop User Log(s) to stop recording the data file. 

Data Log Filename and Path 

This pane displays the filename and path of the active data log. The indicator is grayed-out if there is no active 

data log (i.e., if a new data log has not been started using the Start User Log(s) button). A new file will be 

generated at midnight, which will be saved to the same location as the original log file. 

Status Log Window 

This window displays instrument status messages in the following form: 

“MM/DD/YYYY hh:mm:ss generic message text.” These messages include all messages sent to the DAS. 

Data Source and Data Key Drop-Down Menus 

These two menus determine the data stream information that is viewed in the Data Windows. Data streams 

available on the GUI are gas concentrations. If ‘Instrument Analysis’ is selected for a source (where 

instrument represents the system installed), or if “sensors” is selected for a source, then the following can be 

viewed: 

• The analyzer’s optical cavity pressure or temperature 
• The analyzer's nominal ambient temperature (“DAS temp”) 
• The temperature of the analyzer’s electronics chamber, indicated as “warm chamber temp.” 
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Precision Drop-Down Menu 

This menu allows you to select the precision that is displayed on the Y-axis. You can choose values 

between 0 and 4 digits of precision, or you can specify “auto”. The currently selected precision is 

displayed during operation. 

 The precision specified here does not affect the precision of the saved data in the data log files or results 

files. 

Auto-Scale Y 

The Auto-Scale Y button auto-scales the Y-axis of the data window graphs. 

Reset Buffers 

The Reset buffers button clears the internal data buffer of the GUI (i.e., clears the current data traces 

from the graphs). This has the effect of clearing all data in the data window. 

 Pressing this button has no effect on any of the data log files stored by the instrument. It only clears the 

data windows. 

Data Buffer Level Meter 

The meter to the right of the data windows indicates how much of the GUI internal memory is used to retain 

historical data collected with the Picarro G4301. There is an internal limit with a finite number of points. 

Once that number of data points is collected, the buffer is full, and old data is removed from the buffer as new 

data is collected. 

This buffer affects only the data displayed in the data window, not the data stored in any files. This buffer is 

empty upon instrument startup and can be emptied by pressing the Reset Data Buffer button. 

Data Windows 

The data windows show graphs of any stream of data vs. system time, with a format of hh:mm:ss. Users can 

select which data stream are displayed using combinations from the Data Source and Data Key drop-down 

menus. The precision displayed can be adjusted using the Precision drop-down menu and the Auto-scale Y 

button. 

These graphs are interactive. To zoom the graph, drag the magnifying glass over the section to be zoomed, 

and then click and hold the left mouse button. While holding down the left button, move the mouse to create a 

box that covers the region of interest. When the box is properly drawn, release the left button, and the boxed 

area will automatically scale to fill the data window. To zoom back out, double click on the left button. To 

auto-scale the Y-axis of either graph, use the Auto-scale Y button below the graph. To lock or unlock the time 

axes of each graph during zooming, select that menu item in the ‘View’ menu. 
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File Management 

During operation, the analyzer generates various ASCII-format text output files that are updated after each 

batch of concentration measurements is complete. For example, one of the user output files is named: 

CFADS##-yyyymmdd-hhmm-DataLog_User_Sync.dat, where “CFADS##” (or similar) is the instrument serial 

number. 

The file name is generated from the instrument serial number, the date, and the time when the instrument was 

started. For example: 

CFADS01-20160127-1029-DataLog_User_Raw.dat 

CFADS01 is the instrument serial number 

20160127 is the date, 1/27/2016, formatted as yyyymmdd. This format ensures chronological sorting of 

data files. 

1029 is the time when the file was started, 10:29 am, formatted as hhmm, using a 24-hour clock. 

The raw user data is contained in folders in the following directory: 

C:\UserData\Minimal\[year]\[month]\[day]\hour 

This is data that has not been re-sampled to exact 0.1s time intervals. There is a similar directory, 

C:\UserData\DataLog_Sync\..., that includes data that is evenly spaced in time at the data rate of the 

analyzer. 

Data files are created every 15 minutes and stored for 90 days before they are automatically deleted. The file 

deletion frequency and details can be modified in the file: 

C:\Picarro\G2000\AppConfig\Config\Archiver\Archiver.ini 

 

Analyzer Data Files 

During data acquisition, the analyzer creates directories to store the data based on the date when the data 

were acquired. After each data file has been closed (every 15 minutes), the file is moved to an archive 

directory, and a new file is started in the original location. The archive directory is: 

C:\Picarro\G2000\Log\Archive\ 

This archive directory has subdirectories: DataLog_Mailbox, DataLog_Private and DataLog_EventLogs. 

The files within these subdirectories are arranged by year\month\day\hour. 

There are more complete data files that include additional information beyond the concentration data, 

including parameters such as instrument temperatures and pressure, setpoints, and spectroscopic 

information. This information is generally not useful to the user, but it can be useful for diagnostic purposes. 

This information is stores in the directory: 

C:\Picarro\G2000\Log\Archive\DataLog_Private \[year]\[month]\[day]\[hour] 

For more information about how to include various columns of data from the DataLog_Private file in the 

C:\UserData folder, please contact Picarro. 
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Current Data Files 

The current data file can be found in: C:\Picarro\G2000\Log\DataLogger\ 

This directory includes subdirectories: DataLog_Private, DataLog_User_Raw and DataLog_User_Sync. 

Similarly, the archive directory has subdirectories arranged by file type. The subdirectories are further 

organized by \[year]\ [month]\[day]\[hour]. 

Data File Generation 

To keep the data files easy to manage and to limit the size of individual files and directories, the software 

automatically generates new files each time the instrument is powered up and also at midnight each night. 

When a new file is created at midnight, its file name will contain the new date and a time of 00:00. For example 

if the system was started at 10:29 am on 2/5/2016 it would create a file named: 

20160205\CFADS01-20160205-1029-UserLog.dat 

Then at midnight a new file will be created: CFADS01-20160206-0000-UserLog.dat 

File Archival 

The analyzer can automatically compress (zip) and archive old files as mentioned previously. This operation is 

controlled by the following ini file: 

C:\Picarro\G2000\AppConfig\Config\Archiver\Archiver.ini 

For each file type, there are various items along with some recommended default settings, which may vary by 

file type: 

Directory = C:/UserData/DataLog_Sync 

Optionally specifies which directory to find files to archive. 

MaxCount = -1 

Specifies how many files to keep. A setting of -1 indicates that there is no maximum number of files. 

Generally -1 is used in conjunction with a maximum size limit, below. 

MaxSize_MB = 1500 

Specifies that a maximum of 1.5 GB of data is to be kept before the system begins todelete old data. 

Compress = True/False 

Specifies if archived files are to be zipped – recommended setting is true to save hard drive space. True 

means files are zipped, false means files are not zipped. 

AggregationCount = 0 

If compression is set to TRUE, specifies how many files to be included in each zip archive. 

 

StorageMode = FIFO 

First in first out. Specifies that old data is deleted first. 
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Quantum = 4 

Generally should not be changed. Specifies the files be sorted by year\month\day\hour in the archived 

directory structure. 

Automatic Deletion of Old Files 

In addition to automatic file and directory management, the analyzer also automatically deletes various files 

specified in 

C:\Picarro\G2000\AppConfig\Config\FileEraser\FileEser.ini  

This file includes the following configurable settings: 

runtime_interval_hrs = 0.5 

Specifies how often in hours to run the file eraser. 

path = ../../../Log/Archive/DataLog_Private 

Specifies the directory to be searched for the files to delete. 

extension = dat 

Specifies the file extension to search for when deleting. If configured, then only files with this extension 

will be deleted. If empty, then all files will be deleted. 

delete_time_hrs = 48 

Specifies how long to keep files prior to deletion. 
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CHAPTER 7 Data File Viewer 

Picarro Data File Viewer 3.0 is a standalone program that allows you to display and analyze Picarro data 

files and to concatenate and convert the data file formats. Data File Viewer also supports Python scripting 

for data manipulation and plotting. 

With Data File Viewer you can: 

• Filter data based on a combination of criteria, e.g., time, valve state, concentration range, species ID, 

etc. 

• Change the time zone and convert time unit (e.g. date/time vs elapsed time) 

• Gather files from specific date ranges 

• Capture current settings and save in configuration files 

• Export data and images 

File Concatenation and Format Conversion 

• Concatenate data files in a specific time range 

In the Data File Viewer UI, go to File > Concatenate H5 Files. After selecting the target folder, a 

Select Variables dialog will display. Click Define date range to specify time range for file 

concatenation. Please keep the following mind with regards to the time range: 

• A Picarro data file is named with the creation time. Data File Viewer uses the file name to 

determine whether the data file is within the specified time range. If the file name has ever been 

changed, then do not use the Define date range option. Instead, try concatenating all files first, 

and then use the next method (immediately below) to save data in the specific time range. 

• Data File Viewer does NOT concatenate data files exactly within the specified time range. 

Usually, the resulting dataset has a wider time range than the user specification. Perform the 

following steps to accurately define the date and time range. Refer to Define Date Range (page 

31) for more information. 

(a) Load the concatenated dataset in Data File Viewer and make a time series plot for any 

variable. 

(b) Right-click on the time-series plot canvas, and select Edit Plot Properties. 

(c) Define the time range for the X-axis in the Image Editor form, then close the form. This returns 

you to the canvas. 
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• Concatenate a large volume of data files 

In some cases, you may want to concatenate data files of several hundreds of MB or even larger. To 

do this, select the Large dataset checkbox in the Select Variables form. For normal file 

concatenation, Data File Viewer loads data into memory and then sorts datasets based on the time 

before writing into a file. This can easily cause a memory error if a large volume of data files are 

concatenated. With the Large dataset option, Data File Viewer writes data directly into the hard disk 

to save memory space. This way, Data File Viewer can handle a very large dataset without causing a 

memory error. 

Keep in mind that, because the data is written directly into the hard disk without sorting, the resulting 

datasets may not be in chronological order. To ensure the correct chronological order of the datasets, 

data files need to be saved in directory trees named by date and time, and data files need to be 

named with the creation time (just like data files in the DataLog_Private folder). This way, Data File 

Viewer can write files to the hard disk in the correct chronological order. 

The Data File Viewer UI 

The Picarro Data File Viewer UI includes two main menus: File and New. 

 

Figure 20. File menu 

 

Figure 21. New menu 
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The File Menu 

This section describes the functions available from the Data File Viewer File menu. 

Open H5 

File > Open H5 opens a Picarro data file (HDF5 format) for data analysis and visualization. After opening the 

data file, you can create a new time series plot. Refer to New Time Series Plot for more information. 

Load Config 

File > Load Config loads a configuration file (ini format) to restore parameters of a workplace. Refer to Save 

Configuration  for more information. 

Unpack Zip File 

Use File > Unpack Zip File to concatenate all H5 files inside the zip file into a single H5 file. Refer to 

Concatenate H5 Files for details. 

Concatenate H5 Files 

Use File > Concatenate H5 files to concatenate multiple files and zip archives of H5 files into a single H5 

file. Navigate to the desired folder, or use the Define date range button to specify a date range of files to 

concatenate. (See next section.) 

After selecting the path of the data files, Data File Viewer will automatically search an H5 file in the 

specified zip/folder and look for all available variables in the H5 file. The variables are then listed in the left 

panel, and users can use “>>” button to move variables to the right panel for concatenation. 
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Figure 22. Select Variables form 

DEFINE DATE RANGE 

Data File Viewer can search data files within the desirable date range and then concatenate such files 

into a H5 file. 

By default, TimeZone is set to your local timezone. However, if data were taken elsewhere, select the 

timezone where data were taken. 

Select File > Concatenate H5 files, then click Define date range to specify the desired date range. 

 

Figure 23. Defining a date range 

Data files are saved in directory trees named by date and time option.  
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Picarro software saves data in a directory tree that is named by the creation year, month, and day. 

(See example directory tree in the following image.) Select this option if the target folder has this file 

structure. This way, Data File Viewer will only search folders within the desirable date range, which 

can substantially reduce processing time. 

 

Figure 24. Data File Viewer file structure using creation year, month, and day 

 To save processing time, Data File Viewer does not open data files, but only determines data acquisition 

time based on the file name. 

 

 DO NOT DEFINE A TIME RANGE FOR DATA FILES WHOSE NAMES HAVE BEEN CHANGED. 

 

 Data File Viewer does not concatenate data files exactly within the defined time range. This is because 

the time extracted from file name is different from the data acquisition time. In order to not miss data 

points, Data File Viewer expands the specified time range, so the resulting dataset normally has a wider 

time range than the user specification. 

Convert DAT to H5 

Select File > Convert DAT to H5 to convert a file in DAT format to HDF5 format. These formats are 

described below: 

• DAT format: DAT files accepted by DatViewer store tabular data (numbers and text) in plain text. 

o Each line of the file is a data record. Each record consists of one or more fields separated by 

whitespaces. 

o The first line of data file indicates column names. 

o There must be a field “EPOCH_TIME” to store the acquisition epoch time (expressed as seconds 

since Jan 1, 1970) of the data. Otherwise, the first and second fields must be “DATE” and “TIME”. 

The “DATE” field must have the format “mm/dd/yyyy” or “yyyy-mm-dd”, and the “TIME” field must 

have the format “HH:MM:SS(.sss)” where (.sss) is an optional fraction of seconds. 

• HDF5 format: HDF5 is a data model, library, and file format for storing and managing data. (See the 

HDF5 Home Page on the HDF Group Web site for more information.) When converting DAT to HDF5 

format, Data File Viewer creates a table named “results” to the contain data. 
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Convert H5 to DAT 

Select File > Convert H5 to DAT to convert a file in HDF5 format to DAT. These formats are described in 

Convert DAT to H5. 

 When converting H5 to DAT format, each column has a fixed width of 26 characters. If column headings 

are too long (more than 25 chars), Data File Viewer will convert or truncate them. For example, column 

name “fineLaser-Current_1_controlOn” will be replaced with “fineLaserCurr_1_ctrlOn”. 

Interpolation 

Interpolation describes the method for constructing data points with a range of a discrete set of known 

data points. Select File > Interpolation to perform interpolation on a time grid with a constant interval. 

Block Average 

Select File > Block Average to divide a dataset into small blocks based on a user-defined block size. 

The average is calculated for data in each block, and the results are saved in a new H5 file. 

 The specified block size must be greater than the average data interval. 

Because the data interval is normally not a constant (unless interpolation is performed), fluctuations in the 

data interval will affect block averaging if the block size is comparable to the average data interval. 

New Time Series Plot 

You can specify to include create time-series plots with one, two, or three frames. New plots display in the 

Time Series Viewer. 

 

Figure 25. Time Series Viewer - two frames 
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The next section describes the options available on the Time Series Viewer menu bar. Refer to The Time 

Series Viewer Canvas (page 37) for information the Time Series Viewer UI features and options. 

Time Series Viewer Menus 

The Time Series Viewer form includes the following menus: 

 

Figure 26. Time Series Viewer menus 

These menus are described in the sections that follow. 

TIME SERIES VIEWER FILE MENU 

Use the File menu to save a configuration or take a screenshot. 

 

Figure 27. File menu 

Save Configuration 

Click File > Save Configuration to open the Feature Capture form. With this form, you can save figures 

properties, expressions, filters, and other settings to a configuration file so that it can be easily loaded in the 

future. 

 

Figure 28. Feature Capture form 

 If a feature is not captured, it will be omitted when the configuration file is loaded. 

Depending on the features captured, loading a configuration file can have different effects. For example: 
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• If all features are captured, a saved workplace is reproduced. 

• If Data file is not captured, saved parameters will be applied to the data file in memory. 

• If Expression is not captured, plots will not be transformed. 

• If X (Y) range is not captured, figures will be auto scaled on the x (y) axis. 

Take ScreenShot 

Use File > Take ScreenShot to take a screenshot of the Time Series Viewer and save it as a .png to a 

specified file. 

TIME SERIES VIEWER ANALYSIS MENU 

Use the Analysis menu to calculate statistics, generate a histogram, and to plot correlations and Allan 

Standard deviations. 

 

Figure 29. Analysis menu 

Statistics 

Use Analysis > Statistics to calculate mean, standard deviation and peak to peak for all plots in the 

current window. 

Histogram 

Use Analysis > Histogram to generate a histogram of data as shown below. 



  

Picarro G4301                           User’s Instruction Manual  37 

 

Figure 30. Analysis > Histogram window 

Red Line: A Gaussian function fitted to the histogram. Fitting results of μ and σ are shown in the top-left 

corner of the plot. 

• Bin: Specifies the number of intervals that the range of values is divided into. 

• Normalized: When selected, the sum of the histograms is normalized to 1. 

• Save data: Saves histogram data to a CSV file. 

• Save image: Saves the histogram image as a JPEG/PNG/PDF file. 

Correlation Plot 

Use Analysis > Correlation Plot to plot Y-axis data in one frame versus that in the other. This can be 

used when two or more frames exist in the current Time Series Plot window. See Correlation/XY Plot for 

details. 

Allan Standard Deviation Plot 

Use Analysis > Allan Standard Deviation Plot to create an Allan Standard Deviation plot (versus a 

standard deviation plot) for data in the current window. See Allan Variance for more information. 

TIME SERIES VIEWER VIEW MENU 

Use the View menu to view X-axis information in datetime, minute, or hour format. 

 

https://en.wikipedia.org/wiki/Allan_variance
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Figure 31. View menu 

 When switching from Datetime to Minute or Hour, the X-axis data is subtracted by the earliest point 

shown in the panel and then converted to the desired unit. 

The Time Series Viewer Canvas 

The Time Series Viewer canvas is comprised of interactive graphs and a variety of configuration options. 

 

Figure 32. Time Series Viewer canvas 

Refer to the following for more information: 

• Mouse Options and Graph Transform  

• Right-Click Menu 

• Data Set Name and Var Name  

• Expression 

• Autoscale Y 

• Average 

• Mean, Std Dev, and Peak to Peak 

• Filter 
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MOUSE OPTIONS AND GRAPH TRANSFORM 

The following mouse actions can be used in the canvas graphs: 

• Left click and drag: Zooms in to the selected area of the plot. 

• Left click and drag with SHIFT key down: Pans the plot. 

• Left click and drag with CTRL key down: Zooms out from the plot. 

• Left click and drag with ALT key down: Stretches the plot. 

• Right click: Opens an additional menu. Refer to the next section. 

RIGHT-CLICK MENU 

Right-clicking on the canvas provides opens a pop-up menu. 

 

Figure 33. Canvas right-click menu 

Export Image: Exports the current plot as a jpeg, png, or pdf file. 

Export Data in Current View: Exports only date/time and the selected variable in the current view to an 

HDF5 or CSV file. 

Export All Data in Current Time Range: Exports all variable columns of the selected dataset in the 

current time range to an HDF5 file. Refer to Concatenate H5 Files (page 31) for more information. 

Edit Plot properties: Opens the Image Editor form, where the following options can be specified: 

• Title: Edits the title of the plot. 

• Line: Specifies the line pattern of the plot. If None is selected, then data points will plotted without 

connecting lines. 

• Marker: Specifies the marker type to indicate data points. If None is selected, data points will not be 

shown. 

• Min and Max: Specifies the minimum and maximum of data range for the X-axis and the Y-axis. 

• x[0]: Sets the earliest time of the dataset as the minimum of the X-axis. 

• Time zone: Sets the time zone for date/time variables. This defaults to the local time zone. 

• Label: Specify a label for the X-axis and the Y-axis. 
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Figure 34. Image Editor form 

Statistics: Calculates the mean, standard deviation, and peak to peak for data in the current view. 

DATA SET NAME AND VAR NAME 

An HDF5 file can store one or more tables. Each of these tables is called a Data set. A table can contain 

one or more columns. Each column is called a variable (Var). 

Use the Data set name drop down to select the dataset that will be used for this time series graph. Use 

the Var name drop down to select the column in the dataset to use in the graph. 

EXPRESSION 

An expression is a mathematical function that applies on the selected data and transforms the plot. For 

example: 

y + CO2 

In this expression, y is the data of selected variable (y-axis data of the plot), and CO2 is the data of CO2 

column in selected table. As a result, this expression transforms the plot to be summation of selected the 

variable and CO2 data. 

 All variables in the selected dataset can be used in the Expression field by calling the variable name. 

However, if a variable name starts with a number, it must be appended with a prefix of “dat”. For 

example, “12CO2” must be called “dat12CO2” in the Expression field. In addition, x and y are defined 

as short-cuts for x-axis and y-axis data of the plot, correspondingly. 

 

 The Expression field is applied after Filter but before Average. 

AUTOSCALE Y 

When the Autoscale Y option is selected, the Time Series Viewer will autoscale on the Y-axis to make 

sure that all data within the range of the X-axis is displayed. 
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AVERAGE 

If Block is selected, a block average is calculated when you click the Do average button is clicked. 

Otherwise a moving average is calculated. 

For a block average, Size specifies block size in unit of minute. For a moving average, Size specifies 

subset size in unit of data points. 

 Averaging is performed after the Filter and Expression are performed. 

MEAN, STD DEV, AND PEAK TO PEAK 

The Mean, Std dev (Standard deviation) and Peak to peak fields provide all of the statistical information 

of data in the current view. 

FILTER 

Filter is a mathematical expression that specifies data to include or exclude from plot(s). For example: 

(CH4 < 5) & (CO2 < 10) 

In this example, CH4 and CO2 are both variable names in the selected data set. As a result, this filter 

removes all rows that have CH4 >= 5 or CO2 >= 10 from dataset. 

Available logical operators for the Filter field are: 

& (AND) 

| (OR), 

~ (NOT) 

^ (XOR) 

 All variables in the selected dataset can be used in the Filter field by calling the variable name. However, 

if variable name starts with a number, it must be prepended with a prefix of “dat”. For example, “12CO2” 

must be named “dat12CO2” in the Filter field. 

 

 A Filter is applied before an Expression. 

Correlation/XY Plot 

The Correlation/XY Plot includes two menu items: File and Analysis. 

• For details about the File menu, see Save Configuration. 

• For details about the Analysis menu, see Analysis Menu. 

The canvas in this plot is interactive. For details about the plot canvas, see The Time Series Viewer 

Canvas. 
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Figure 35. Correlation/XY plot 

Analysis Menu 

The Analysis Menu includes three options. These options are described in the sections that follow. 

• Fitting 

• Integration 

• Statistics 

 

Figure 36. Analysis menu 

FITTING 

The fitting menu allows you to specify the fitting method to include in the Correlation/XY plot. 

• Linear fit: Specifies to fit to linear function y = c1x + c0 

• Quadratic fit: Specifies to fit to quadratic function y = c2x2 + c1x + c0 

• Polynomial fit: Specifies to fit to polynomial function of degree n: y = Σcnxn 

• Curve fit: Specifies to use non-linear least squares to fit an arbitrary function to data. This option 

opens the following menu: 
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Figure 37. Curve fitting 

The Initial guess values are important for curve fitting. Try to make a best guess for the specified 

parameters. 

If the Fit function is a polynomial function, then it is better to use the Polynomial Fit method instead of 

Curve Fitting. 

INTEGRATION 

Integration specifies to calculate the area under the curve using the composite trapezoidal rule. 

STATISTICS 

Statistics specifies to calculate the mean, standard deviation and peak to peak for data in the current 

view. 
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CHAPTER 8 Calibration Procedure 

Calibrating your Picarro analyzer involves three steps: 

1. Measuring the concentrations of known standards with the analyzer. 

2. Determining the relationship between the measured value and the known value. 

3. Adjusting the settings on the analyzer to correct for any difference between the measured and known 

values so that the on-screen readings are accurate. 

Standard Gas 

Because the Picarro Analyzer is extremely linear, it is only necessary to use three calibration standards to 

calibrate each gas species. (Two points define the calibration line, and a third intermediate point is used 

for verification.) The concentration value of each calibration standard is not of particular importance as 

long as they span a representative range of values over which the analyzer will typically be operated. It is 

reasonable to use a concentration of zero for the low calibration value, for example. Although it is not 

necessary to use more than three standards, additional standards can be used to further constrain the 

linear calibration coefficients. 

Calibration Methodology 

To perform a calibration or verification of calibration, the user simply introduces the calibration standard 

into the analyzer for a period long enough for the analyzer to yield a stable measurement of that sample. 

Setup 

This section describes the connections from the analyzer to the gas tank. 

• The pressure regulator at the outlet of the gas tank protects the analyzer from over-pressurizing. The 

pressure should be set to about 1 psi. 

• The toggle valve allows rapid shutoff of the gas delivery. 

• Tubing is connected to the male quick-disconnect connector provided with the analyzer. 

• The male connector is inserted to the inlet port of the analyzer. 

To replace the gas tank:  

1. Turn off the main valve on the gas tank. 

2. Disconnect the pressure regulator assembly from the tank. 

3. Connect the pressure regulator assembly to the next gas tank. 
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Figure 38. Connecting a gas tank to the analyzer 

Measurement Time for Each Standard 

The measurement period for a calibration standard is dependent upon the recorded precision of the 

standard gas and performance characteristic of the analyzer. (See the Allan variance plot that follows.) 

For instance, if the reported absolute accuracy of the CO2  standard is 0.1 ppm, the averaging time to 

achieve that precision for a single measurement is 20 sec. Furthermore, if measurements are taken for 5 

min (300 sec), using the Allan standard deviation plot tells us that we can reach precisions of 0.1ppb for 

CH4 and 30 ppb for CO2. This level of certainty converts to an absolute accuracy in your standard once 

calibrated 
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Figure 39. Allan variance plot 

Measuring Multiple Gas Standards 

When measuring multiple gas standards, the order of the gas standard is not important. However, make 

sure that you measure the gas standard slightly longer than the time you determined in the previous 

section because the usable/effective data set will be trimmed down. 

 

Figure 40. Measuring multiple gas standards 

Calibration Data Processing 

1. Process the calibration results from the .dat file (see File Management (page 25)), and calculate the 

average recorded value for each standard. 

2. Plot these values versus the certified values from the gas supplier, and determine the linear 

relationship between the known calibration values and the analyzer’s reported values. A linear best-fit 

equation can be calculated from the data. 
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 It is important to plot the analyzer’s reported concentration on the horizontal axis and the gas standards’ 

stated concentrations on the vertical axis. 

The slope and intercept of the best-fit line through these points are the two values that are used to 

calibrate the analyzer. By determining the linear relationship between the known calibration values and 

the analyzer’s reported concentration values in this way, a calibration offset (slope and intercept) can be 

calculated so as to add a correction term to the analyzer’s factory or previous calibration. 

Inputting the Calibration Setting 

Changing the analyzer’s calibration is intended to be done infrequently. Instead of recalibrating frequently 

to increase the accuracy of the data, users often just verify the calibration by measuring three or more 

gas standards and use the same regression procedure described here to calculate an offset by which to 

correct their data offline. Using the following equation in the graph below, this calculation would be 

accomplished point-by-point by calculating the corrected data “y” using the analyzer’s data “x” so that: 

Datacorrected = 0.9866•Dataraw+5.268 

 

 

Figure 41. Linear calibration example 

Calibration values are input into the analyzer by selecting Tools > User Calibration, and then entering 

the slope and intercept for each species. 

 User Calibration is a password-protected form, and the default password is “picarro”. This password can 

be reset in the QuickGui.ini file as previously described. (Refer to Tools Menu.) 

The calibration will take effect immediately after clicking OK. To return to the factory calibration, simply 

set the slope to 1 and the intercept to 0 for each species.  
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CHAPTER 9 Service and Maintenance 

The advanced, rugged design of the Picarro analyzers provides stable, long-term operation with minimal 

service or maintenance. The following items are serviceable: 

• Replacing the battery, PN# S2040 

• Replacing the inlet filter, PN# S1021 

• Replacing the fan, PN# S1071 

• Replacing the pump, PN# S2010 

• Replacing the fuse 

With the exception of these items above, the analyzer is not user serviceable. Should it appear to 

malfunction, please refer to Troubleshooting or contact Picarro. 

Opening the Case 

Open the case to access the internal components. See Figure 42. To open the case: 

1. Release the latches on either side of the case. 

2. Lift the case cover. 

3. Remove the screws from the inner cover (Figure 42). 

4. Open the inner cover 

 

Figure 42. Open the Case 
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Replacing Inlet Filter 

When the inlet filter is clogged or heavily fouled, replace the filter with a new one (PN# S1021) by 

unscrewing the ¼” Swagelok nut. Make sure the filter is installed in the proper direction. 

 

 

Figure 43. Inlet Filter 

 

Replacing Fuses 

Two 3A - 32V Mini Blade fuses are located in the analyzer behind the backplate. They can be replaced by 

simply opening the fuse case cover and pulling out the Mini Blade fuse. 

 

 

Figure 44. Fuses 

 ENSURE THE BATTERY AND POWER OUTLET CABLE ARE DISCONNECTED WHEN REPLACING 

THE FUSES. 
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Replacing Fan 

1. Remove the fan’s power connector from the Analyzer Power Distribution Board. Figure 45. 

 

Figure 45. Analyzer Power Distribution Board 

 

2. Remove the four nuts securing the fan to the inner enclosure. Figure 46. 

3. Pull the fan out and over the ends of the four screws. 

4. Remove the fan. 

 

Figure 46. Remove the Fan 

5. Repeat steps one through four to install a new fan. 
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Replacing Pump 

1. Disconnect the pump power connector. 

2. Disconnect the mother board power connector. Figure 48. 

3. Detach the two USB connectors to access the pump. See Figure 47. 

 

                      Figure 47. Disconnect the USB Connectors 
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4. Release the tie-wrap securing the pump. 

 

Figure 48. Release the Tie-Wrap 

5. Remove the vacuum tubing from the pump 

 

Figure 49. Remove the Vacuum Tubing 

6. Attach the new pump to the tubing. 

7. Reconnect the USB connectors and the mother board power connector. 

8. Close the inner cover and replace the two screws. 

9. Close and latch the outer cover. 
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CHAPTER 10 Troubleshooting 

The following section lists problems that may be encountered during installation and operation of the 

analyzer. The corresponding step-by-step procedures provide resolution in most cases. If, after 

attempting these procedures, the problem remains unresolved, please contact Picarro Technical Support.  

• Power LED on analyzer does not illuminate (page 49) 

• User interface program does not start (page 49) 

• Sample pressure cannot be controlled to the appropriate value for concentration measurements (page 49) 

• User interface program “freezes” and does not update graphs as data are collected (page 50) 

1. Power LED on analyzer does not illuminate 

Context: Turning on the analyzer by momentarily depressing its front panel power switch 

should apply power. The green power LED is illuminated when it detects the correct power 

levels. 

a) Check that the AC power cord is attached and plugged into a working outlet. 

b) Check that the rear on-off switch near the AC power cord is in the on position. 

c) Press and hold the front panel power switch for at least 5 seconds as the analyzer may take several 

seconds to respond. 

 

2. User interface program does not start 

Context: The computer may be configured to start the instrument and the associated user 

interface program automatically after it completes its bootup sequence, or the program may 

be launched using the “Start instrument” icon on the desktop. 

a) Communications problems with the analyzer may occur if the analyzer fails to initialize correctly on 

power up. Should the analyzer initialization process not complete correctly, shut down the instrument 

by shutting down the Windows operating system on the control computer: use the Start menu, select 

the red Shut down button and select “Shut down” in the drop-down box under “What do you want the 

computer to do?”. Wait for the shutdown to complete normally and for the computer and analyzer to 

turn off completely. After a few seconds, restart the computer by momentarily depressing the power 

button. 

 Do not simply restart Windows because this does not cycle the power to the analyzer. 

3. Sample pressure cannot be controlled to the appropriate value for concentration 

measurements. 

Context: Under normal operation, the cavity pressure is automatically locked to the correct value by 

means of electronically controlled inlet and outlet valves. The message “Pressure Locked” on the 

front panel display and the user interface indicates that the cavity pressure is at the appropriate value. 

Should either of the messages “Pressure high” or “Pressure low” be displayed, the cavity pressure is 

out of its correct operating range. 
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a) The “Pressure low” message indicates that there is insufficient gas available at the inlet of the 

analyzer. Check the inlet plumbing to the analyzer and ensure that the pressure at the inlet is 

within the specifications.  

b) The “Pressure high” message indicates that gas cannot be removed from the analyzer at a 

sufficient rate. Check the vacuum line between the analyzer and the power vacuum unit for leaks. 

Failure of the vacuum pump, injecting dilution gas at excessive pressure, or excessive pressure 

at the inlet can also cause this problem. 

4. User interface program “freezes” and does not update graphs as data are collected 

Context: The computer may become unresponsive causing the programs that control the analyzer to 

stop functioning. The computer and analyzer should be shut down and restarted. 

a) Re-setting the computer and the instrument requires that the computer be shut down and 

restarted. If the computer responds to the mouse, a normal Windows shutdown may be carried 

out: use the Start menu, select the red Shut down button and select “Shut down” in the drop-

down box under “What do you want the computer to do?” Wait for the shutdown to complete 

normally and for the computer and analyzer to turn off completely. After a few seconds, restart 

the computer by momentarily pressing the power button. 

b) If the computer does not respond to the mouse, hold down the power switch on the front panel for 

a few seconds until the computer and the instrument turn off. After another few seconds, restart 

the analyzer by momentarily pressing the power button. 
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CHAPTER 11 Return Merchandise 
Authorization 

Picarro, Inc. reserves the right to revise the RMA process and to make changes from time to time. 

DAMAGE IN SHIPMENT - Your analyzer should be inspected and tested as soon as it is received. The 

product is packaged for safe delivery. If the product was shipped Ex Works Santa Clara, CA (or similar 

designation under INCOTERMS), then you should immediately file a claim with the carrier or, if insured 

separately, with the insurance company. Otherwise, please contact Picarro immediately to report any 

damage. 

ADJUSTMENT – No electrical, mechanical or optical adjustments to the product(s) are permitted. 

REPORTING A DEFECT, WARRANTY REPAIR OR OTHER PROBLEM - Customers must obtain a 

Return Merchandise Authorization Number from Picarro, Inc. prior to returning any product, peripheral or 

component. 

Products being returned for repair must be shipped in their original shipping cartons or similar to avoid damage. 

The Purchaser’s exclusive remedy with respect to any defective Product shall be to have Picarro repair or 

replace such defective Product or credit the Purchaser’s account, whichever Picarro may elect in its sole 

discretion. If it is found that any Product has been returned which is not defective, the Purchaser will be 

notified and such Product returned at the Purchaser’s expense. In addition, a charge for testing and 

examination may, at Picarro’s sole discretion, be made on any Product so returned. 

These remedies are available only if: i) Picarro is notified in writing by the Purchaser promptly upon discovery 

of a Product defect, and in any event within the warranty period; ii) Picarro’s examination of such Product 

discloses to Picarro’s satisfaction that such defects actually exist and the Product has not been repaired, 

worked on, altered by persons not authorized by Picarro, subject to misuse, negligence or accident, or 

connected, installed, used, or adjusted otherwise than in accordance with the instructions furnished by 

Picarro. 
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APPENDIX A DataLog_User and 
DataLog_Private Parameters 

This section describes the parameters that are avaialble in the DataLog_User and DataLog_Private files. 

DataLog_User Parameters 

The following table describes the columns available in the DataLog_User file. 

Table 5. DataLog_User Parameters 

Column Description Units (if applicable) 

DATE Date of measurement(UTC) Year-Month-Day 

TIME Time of measurement (instrument time, GMT) Hour:Minute:Second.m

s 

FRAC_DAYS_SINCE_JAN1 Fraction of days since Jan 1 (max = 365)   

FRAC_HRS_SINCE_JAN1 Fraction of hours since Jan 1 (max = 8760)   

JULIAN_DAYS Julian days in since Jan 1 00:00 GMT   

EPOCH_TIME Number of seconds that have elapsed since Jan 1, 1970 

GMT 

  

ALARM_STATUS Binary system alarm (0 = no alarm; 1 = alarm)   

INST_STATUS Hardware status code; should always equal 963 if the 

analyzer is operating properly 

  

H2O Mole fraction of water vapor Percent 

CH4 Mole fraction of methane, not corrected for effect of 

water vapor 

PPM 
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Column Description Units (if applicable) 

CH4_dry Dry mole fraction of methane, corrected for line shape 

effects and dilution by water vapor 

PPM 

CO2 Mole fraction of carbon dioxide, not corrected for effect 

of water vapor 

PPM 

CO2_dry Dry mole fraction of carbon dioxide, corrected for line 

shape effects and dilution by water vapor 

PPB 

CavityPressure Cavity Pressure Torr 

CavityTemp Cavity Temperature deg C 

Battery_Current Current flow to the analyzer battery Ampere 

Battery_Temperature Temperature of the battery deg C 

Battery_Voltage Voltage output of the battery Volt 

 

DataLog_Private Parameters 

The following table describes the columns available in the DataLog_Private file. 

Table 6. DataLog_Private Parameters 

Column Description Units (if 
applicable) 

ALARM_STATUS Binary system alarm (0 = no alarm; 1 = alarm)   

AmbientPressure Not used   

Battery_Charge Proxy for charge held in battery Coulombs 

Battery_Current Current output of battery Ampere 

Battery_Temperature Temperature of battery deg C 

Battery_Voltage Voltage output of battery Volt 

CH4 Mole fraction of methane, calibrated but not corrected for 

effect of water vapor 

ppm 
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Column Description Units (if 
applicable) 

CH4_dry Dry mole fraction of methane, calibrated and corrected 

for dilution and line shape change by water vapor 

ppm 

CO2 Mole fraction of carbon dioxide, calibrated but not 

corrected for effect of water vapor 

ppm 

CO2_dry Dry mole fraction of carbon dioxide, calibrated and 

corrected for dilution and line shape change by water 

vapor 

ppm 

CavityPressure Cavity Pressure Torr 

CavityTemp Cavity Temperature deg C 

DasTemp Temperature measured on the data acquisition system 

board 

deg C 

Delta Isotopic Deviation for 13CO2 to 12CO2 Percent 

Etalon1 ADC output from photodiode monitoring etalon 1 

transmission in wavelength monitor (WLM) 

DN 

Etalon2 ADC output from photodiode monitoring etalon 2 

transmission in WLM 

DN 

EtalonTemp Temperature measured at the WLM dec C 

FRAC_DAYS_SINCE_JAN1 Fraction of days since Jan 1 (max = 365)   

FRAC_HRS_SINCE_JAN1 Fraction of hours since Jan 1 (max = 8760)   

FanState Binary output fan (off/on)   

Flow1 Not used   

H2O Mole fraction of water vapor percent 

HotBoxHeader DAC output to hot box heater controller DN 

HotBoxHeatsinkTemp Temperature measured at the hot box heatsink dec C 

HotBoxTec DAC output to hot box thermoelectric cooler DN 

INST_STATUS Hardware status code; should always equal 963 if the 

analyzer is operating properly 
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Column Description Units (if 
applicable) 

InletValve DAC output to proportional valve at cavity inlet DN 

JULIAN_DAYS Julian days since Jan 1 00:00 GMT   

Laser1Current Current to Laser 1 mA 

Laser1Tec DAC output to Laser 1 thermoelectric cooler DN 

Laser1Temp Temperature of Laser 1 dec C 

Laser2Current Current to Laser 2 (not used on this analyzer) mA 

Laser2Tec DAC output to Laser 2 thermoelectric cooler DN 

Laser2Temp Temperature of Laser 2 dec C 

Laser3Current Current to Laser 3 (not used on this analyzer) mA 

Laser3Tec DAC output to Laser 3 thermoelectric cooler DN 

Laser3Temp Temperature of Laser 3 dec C 

Laser4Current Current to Laser 4 (not used on this analyzer) mA 

Laser4Tec DAC output to Laser 4 thermoelectric cooler DN 

Laser4Temp Temperature of Laser 4 dec C 

MPVPosition Integer code for the valve position   

cal_enabled Binary flag set to 1 if WLM calibration is enabled DN 

ProcessedLoss1 Not used   

ProcessedLoss2 Not used   

ProcessedLoss3 Not used   

ProcessedLoss4 Not used   

Ratio1 Ratio of etalon to reference output for etalon 1 Floating point number  

Ratio2 Ratio of etalon to reference output for etalon 2 Floating point number  
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Column Description Units (if 
applicable) 

Reference1 ADC output from photodiode monitoring etalon 1 

reference beam in WLM 

DN 

Reference2 ADC output from photodiode monitoring etalon 2 

reference beam in WLM 

DN 

SchemeTable Location of this data set in scheme used to control data 

acquisition 

  

SchemeVersion Version number for scheme used to control data 

acquisition 

  

SpectrumID Integer code identifying the spectrum used to generate 

this line of data (=23 for H2O and CH4, 10 for CO2 

Integer 

ValveMask Integer code describing the state of the valve sequencer   

WarmBoxHeatsinkTemp Temperature measured at the warm box heatsink deg C 

WarmBoxTec DAC output to warm box thermoelectric cooler DN 

WarmBoxTemp Temperature measured at the warm box deg C 

cal_enabled Binary flag set to 1 if WLM calibration is enabled   

cavity_pressure Cavity Pressure Torr 

cavity_temperature Cavity Temperature deg C 

ch4_base Background absorption at the frequency of the methane 

peak 

ppb/cm 

ch4_cal Mole fraction of methane after applying instrument-

specific calibration 

ppm 

ch4_conc_dry Mole fraction of methane with water correction but before 

applying instrument-specific calibration 

ppm 

ch4_conc_raw Mole fraction of methane from peak absorption only, 

without water correction or instrument-specific calibration 

ppm 

ch4_fineLaserCurrent ADC output controlling fine current adjustment to the 

methane laser for ring-downs at absorption peak 

DN 

ch4_fit_time Time spent in the fit script for the methane spectrum seconds 
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Column Description Units (if 
applicable) 

ch4_freq_locked Binary flag set to 1 if methane laser frequency is 

centered at methane absorption peak 

  

ch4_gaps Number of gaps in the methane spectrum, i.e. places 

where one or more modes are missing from the data set 

Integer 

ch4_i2f_cubic Cubic term in the current-to-frequency transformation for 

the methane laser 

DN 

ch4_i2f_lin Linear term in the current-to-frequency transformation for 

the methane laser 

DN 

ch4_i2f_offset Constant term in the current-to-frequency transformation 

for the methane laser 

DN 

ch4_i2f_quad Quadratic term in the current-to-frequency 

transformation for the methane laser 

DN 

ch4_interval Time between successive methane spectra seconds 

ch4_laser_temp_offset Offset applied to the temperature controller for the 

methane laser 

dec C 

ch4_max_gap Maximum number of consecutive modes missing from 

the methane spectrum 

Integer 

ch4_peakPoints Number of discrete frequencies at the peak of the 

methane absorption feature 

Integer 

ch4_pointsInRange Number of discrete frequencies in the full methane 

spectrum 

seconds 

ch4_res RMS residual of the fit to the methane spectrum ppb/cm 

ch4_shift Frequency shift between the best fit to the methane 

spectrum and the frequency assignments in the spectral 

library 

wavenumbers 

ch4_slope Fitted slope of the background absorption underlying the 

methane absorption feature 

ppb/cm / wavenumber 

co2_626 Mole fraction of the carbon dioxide 626 isotopologue 

from peak absorption, without correction or calibration 

ppm 

co2_base Background absorption at the frequency of the carbon 

dioxide peak 

ppb/cm 
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Column Description Units (if 
applicable) 

co2_cal Mole fraction of carbon dioxide after applying instrument-

specific calibration 

ppm 

co2_conc_dry Mole fraction of carbon dioxide with water correction but 

before applying instrument-specific calibration 

ppm 

co2_conc_raw Mole fraction of carbon dioxide from peak absorption 

only, without water correction or instrument-specific 

calibration 

ppm 

co2_fineLaserCurrent ADC output controlling fine current adjustment to the 

carbon dioxide laser for ring-downs at absorption peak 

DN 

co2_fit_time ADC output controlling fine current adjustment to the 

carbon dioxide laser for ring-downs at absorption peak 

seconds 

co2_freq_locked Binary flag set to 1 if carbon dioxide laser frequency is 

centered at methane absorption peak 

  

co2_gaps Number of gaps in the carbon dioxide spectrum, i.e. 

places where one or more modes are missing from the 

data set 

Integer 

co2_i2f_cubic Cubic term in the current-to-frequency transformation for 

the carbon dioxide laser 

DN 

co2_i2f_lin Linear term in the current-to-frequency transformation for 

the carbon dioxide laser 

DN 

co2_i2f_offset Constant term in the current-to-frequency transformation 

for the carbon dioxide laser 

DN 

co2_i2f_quad Quadratic term in the current-to-frequency 

transformation for the carbon dioxide laser 

DN 

co2_laser_temp_offset Offset applied to the temperature controller for the 

carbon dioxide laser 

deg C 

co2_max_gap Maximum number of consecutive modes missing from 

the carbon dioxide spectrum 

Integer 

co2_peakPoints Number of discrete frequencies at the peak of the carbon 

dioxide absorption feature 

Integer 

co2_pointsInRange Number of discrete frequencies in the full carbon dioxide 

spectrum 

seconds 
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Column Description Units (if 
applicable) 

co2_res RMS residual of the fit to the carbon dioxide spectrum ppb/cm 

co2_shift Frequency shift between the best fit to the carbon 

dioxide spectrum and the frequency assignments in the 

spectral library 

wavenumbers 

co2_slope Fitted slope of the background absorption underlying the 

carbon dioxide line 

ppb/cm / wavenumber 

dm_latency Interval between successive calls to the data manager 

script 

seconds 

goodCH4 Binary flag set to 1 if methane spectral data set and fit 

pass all fitter tests 

  

goodCO2 Binary flag set to 1 if carbon dioxide spectral data set 

and fit pass all fitter tests 

  

groups Total number of discrete frequencies represented in the 

data set 

Integer 

h2o_cal Mole fraction of water vapor after applying instrument-

specific calibration 

percent 

h2o_conc_raw Mole fraction of water vapor from peak absorption only, 

without correction for line shape effects 

percent 

max_fitter_latency Interval between successive calls to the fitter script seconds 

peak31 Peak absorption of the water vapor line from Levenberg-

Marquardt fit 

ppb/cm 

peak_10 Peak absorption of the methane line from Levenberg-

Marquardt fit 

ppb/cm 

peak_40 Peak absorption of the carbon dioxide line from 

Levenberg-Marquardt fit 

ppb/cm 

rds Number of ring-down measurements comprising the 

spectrum 

Integer 

shift31 Frequency shift between the fitted water and methane 

lines and the frequency assignments in the spectral 

library 

wavenumbers 

spect_duration Time spent acquiring the spectrum seconds 
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Column Description Units (if 
applicable) 

spect_latency Interval bewteen spectrum acquisitions seconds 

spectrumId Integer code designating the spectral region being 

measured (=10 for CO2, 23 for CH4 and water) 

  

str10 Coefficient multiplying normalized Galatry function for 

the methane line, from Levenberg-Marquardt fit 

ppb/cm 

str10_norm Methane line strength normalized by fitted collisional 

broadening parameter 

ppb/cm 

str31 Coefficient multiplying normalized Galatry function for 

the water line, from Levenberg-Marquardt fit 

ppb/cm 

str40 Coefficient multiplying normalized Galatry function for 

the carbon dioxide line, from Levenberg-Marquardt fit 

ppb/cm 

str40_norm Carbon dioxide line strength normalized by fitted 

collisional broadening parameter 

ppb/cm 

str42 Coefficient multiplying normalized Galatry function for 

the carbon dioxide 636 line, from Levenberg-Marquardt 

fit 

ppb/cm 

str43 Coefficient multiplying normalized Galatry function for 

the carbon dioxide 628 line, from Levenberg-Marquardt 

fit 

ppb/cm 

str50 Coefficient multiplying normalized Galatry function for 

the strongest methane line in the carbon dioxide region 

ppb/cm 

temp_correction_ch4 Correction to reported methane mole fraction from 

thermal ground-state population 

Floating point number 

temp_correction_co2 Correction to reported carbon dioxide mole fraction from 

thermal ground-state population 

Floating point number 

temp_correction_h2o Correction to reported water vapor mole fraction from 

thermal ground-state population 

Floating point number 

time Number of milliseconds since midnight Jan. 1, 1970 

(also called EPOCH_TIME) 

milliseconds 

timestamp Unix time stamp for this spectrum  milliseconds 

y10 Collisional broadening parameter for the methane line dimensionless number 
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Column Description Units (if 
applicable) 

y31 Collisional broadening parameter for the water line dimensionless number 

y40 Collisional broadening parameter for the carbon dioxide 

line 

dimensionless number 
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APPENDIX B SFPlite – (If Applicable) 

Optional Soil Flux Processor Lite 

The Soil Flux Processor Lite (SFPlite) is a program that computes the flux of a given area or ground 

usually covered by a soil chamber. The increase in concentration over time is measured by the 

GasScouter and the SFPlite then calculates the flux by fitting to a model that takes in customer inputs, 

including chamber volume, pressure and temperature. 

 

To access the SFPlite, click the designated link left menu of the WebGUI (shown above). This link will 

only be available if additional features are added to the purchasing of the GasScouter. The link will open 

a new tab in your browser, so you will be able to toggle back and forth between the whole data set view 

the WebGUI offers, and the SFPlite calculations. 

 

Above is a picture of the SFP Lite interface where only green icons can be clicked on.  

 

To apply settings of your current experiment to your current measurements click the SETUP icon . Here 

you can input ambient temperature, chamber pressure, chamber volume, and area of ground covered by 

the chamber in cm3. The chamber volume should also account for the volume within the tubing 
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connection the chamber to the analyzer. Chamber pressure is by default set to the measured Cavity 

Pressure + 30 torr, but this can change depending on setup, so it is encouraged to measure this on a 

secondary sensor or app. As an addition feature you can change the different functional form of the fitted 

flux, between a linear, quadratic or Hutchinson & Mosier model. You can also change the name of a new 

SFP .dat file that summarizes calculated flux data. When you click “OK” all of these settings will be saved 

to the instrument and applied until they are changed by the user. 

 

Once you are ready to take a measurement and the chamber is placed, click the PLAY button . The 

graph will be cleared and the ticker will increase to let you know the duration of your measurement. Once 

you have collected enough data for a flux determination click the STOP button . The data is 

automatically fit to the functional form with unites that were chosen in the SETUP menu, and shown at the 

top of the screen. Three green buttons have also been shown available to click, shown below. If you 

would like to trim the data from the beginning or end of the measurement, move the sliders on the bottom 

of the graph to select the desired data to be fit. Once you have selected the portion of data for fitting click 

the REPROCESS botton, . 

 

You now can save the flux to a .csv file located in “C:\UserData\SFPlite” press the SAVE icon, . The 

data file saves flux, chamber characteristics, temperatures, and GPS coordinates (if applicable). It is also 

possible to save comments associated with the current flux measurement in the “Comments” area on the 

Save Results window (shown below); and then click OK once complete. If you do not wish to save the 

data click the DISCARD button , this will automatically clear the screen and wait for you to press the 

PLAY button again. The next flux measurement that you save will be appended to the SFPReport.csv file 

already created. 
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You can now use the Soil Flux Processor Lite to quickly determine soil fluxes. 

 

 NOTE:  If you are using and iPhone or iPad as the tablet device, the screen may become zoomed when 

inputting text, such as comments of volumes. If this happens, click OK to save changes. If the screen 

remains zoomed double tap on any plain gray space that is not ion the graph. This will resize the window 

to fit the screen. Pinching in or out on the map will only rescale the map. 
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APPENDIX C GPS – (If Applicable) 

Adding GPS Capabilities to Data Stream 

This section explains how to add the purchased GPS unit from Picarro to the GasScouter.  

Remove GPS unit from Box. Hang hook part of the plastic body over the cam lever threaded screw on the 

side of the GasScouter chassis. Tighten this down by clamping down the Cam lever, just like a bicycle 

tire. To tighten or loosen the tension on the body of the GPS release the cam lever so that it can be easily 

moved and rotate it clockwise or counter-clockwise, respectively. You want the body to be held firmly by 

the clamp, but you should not have to force the lever down, push it down by holding between with thumb 

and index finger.  

 CAUTION: FORCING THE LEVER DOWN  WITH TOO MUCH FORCE CAN LEAD TO BREAKING 

THE  GPS UNIT CHASSIS OR BRACKET AND RESULT IN MALFUCTION OR IMPROPER 

MOUNTING. 

 

Once mounted plug the USB into the port on the side panel of the GasScouter. Once you turn on the 

analyzer the GPS will be initialized and start logging data into your instrument datastream. Once the data 

is being logged and sent to the instrument you will see a green LED on the USB the flashes every 1 

second. To be sure that your GPS is logging data, you can look at the data from the WebGUI or through 
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the Remote Desktop standard Picarro GUI. The following columns will be added and logging non-zero 

numbers.  

GPS_ABS_LAT Latitude in degrees 

GPS_ABS_LONG Longitude in degrees 

GPS_FIT Quality of GPS data 0-2 

GPS_ALTITUDE Altitude 

GPS_TIME GPS time in seconds 

 

This fills in the columns that are already made in the User Minimal logs found C:\UserData\Minimal. In 

addition to this new files are created found here C:\UserData\GPS_Raw. These files are only created 

when the GPS is logging and initialized with non-zero values. You can see if a current file is being written 

by looking at the normal Picarro QuickGUI and looking in the lower left section and it will show you the 

name and location of the current file. (Shown Below) It also shows the file the current concentration data 

is being written to. 

 

 

 GPS utilizes satellites to define your current position. If the instrument is started without a clear line of 

sight to the open sky the GPS will log zeroes until it obtains signals; hence no GPS log file will be 

started until it gets signal. GPS fits 1 and 2 are the flags for a good GPS signal. 

 

 

 

 

 

 

 

 


